Minimize on close / Notaskbar / Snap / Playpause on tray click

Список разделов foobar2000 Плагины

Описание: Все о плагинах, компонентах, расширениях

Сообщение #61 Sp1ke » 04.02.2009, 13:36

2_DRON_
Ок, понял.
Sp1ke M
Основатель
Репутация: 6
С нами: 17 лет 10 месяцев

Сообщение #62 Hed1n » 08.03.2009, 09:53

Респект создателю и спасибо за добавление поддержки фубара 0.9.4.5!
Маленькое замечание: foo_snap приклеивает окно не к самому верху экрана, а на парочку-другую пикселей ниже. Почему так? Конечно мелочь, но всё таки.. :)
Hed1n
Репутация: 0
С нами: 15 лет 11 месяцев

Сообщение #63 evil » 08.03.2009, 10:40

2Hed1n
Используете левые темы Windows? Проблема в них.
evil M
Репутация: 67
С нами: 17 лет 9 месяцев

Сообщение #64 Hed1n » 08.03.2009, 13:53

И точно, в классической теме всё норм. Впрочем это не проблема, так, для общего развития спросил. Opus OS тема у меня.
Hed1n
Репутация: 0
С нами: 15 лет 11 месяцев

Сообщение #65 DRON » 30.03.2009, 02:34

Чтобы плагины foo_snap.dll и foo_minimize_on_close.dll продолжали работать с версией 0.9.6.4 их надо переименовать, например в foo_snap2.dll и foo_minimize_on_close2.dll.
Ещё можно в Foobar2000.exe (размер 1272320) по смещению 0x16F1B заменить единичку на нолик.
Последний раз редактировалось DRON 30.03.2009, 03:54, всего редактировалось 1 раз.
DRON M
Аватара
Откуда: Санкт-Петербург
Репутация: 113
С нами: 15 лет 10 месяцев

Сообщение #66 GoodVine » 30.03.2009, 12:24

На версии 0.9.6.4 перестал работать foo_snap. Надо что-то сделать.
GoodVine
Репутация: 0
С нами: 14 лет 11 месяцев

Сообщение #67 Mr.Merak » 30.03.2009, 12:31

2GoodVine
переименовать в foo_snap2
Mr.Merak M
Откуда: Украина
Репутация: 27
С нами: 17 лет 6 месяцев

Сообщение #68 GoodVine » 30.03.2009, 12:35

2Mr.Merak спасибо. Ни за что бы не догадался :)
GoodVine
Репутация: 0
С нами: 14 лет 11 месяцев

Сообщение #69 Manhunt » 30.03.2009, 19:34

evil:2zencd
Если пытаться прилеплять сверху, то не до конца получается. Пара пикселей просвечивает.
+1..
ОС Винда ХР СП3, версия фубара 0,9,5,2..
Manhunt M
Аватара
Репутация: 0
С нами: 16 лет 10 месяцев

Сообщение #70 evil » 30.03.2009, 20:49

2Manhunt
Ссыль.
evil M
Репутация: 67
С нами: 17 лет 9 месяцев

Сообщение #71 DRON » 25.04.2009, 23:32

Последняя версия компонент:
http://sharebee.com/4dba78f8
История изменений:
Код: Выделить всё
2008.12.29 Первая стабильная версия
2009.02.03 Добавлена поддержка 71-й версии SDK (соответствует версиям плеера
           с 9.0.0.0 по 0.9.4.5).
           Изменён алгоритм установки хуков: теперь при несовместимости версий
           плагина и FooBar-а, последний не будет падать, а выдаст стандартное
           сообщение о несовместимости с плагином.
2009.04.17 В связи с блокировкой, введённой в версиях 0.9.6.4 и выше, плагины
           переименованы (добавлена двойка в конец имени).
2009.04.25 Добавлен "пустой" сервис для совместимости с версией 0.9.6.5.
2009.05.18 Реализована "мимикрия" PE-заголовков под популярные плагины.
Те кто обновляются с предыдущих версий: НЕ ЗАБУДЬТЕ УДАЛИТЬ СТАРЫЕ DLL-ки, так как файлы были переименованы.
Последний раз редактировалось DRON 18.05.2009, 22:28, всего редактировалось 1 раз.
DRON M
Аватара
Откуда: Санкт-Петербург
Репутация: 113
С нами: 15 лет 10 месяцев

Сообщение #72 alex_realist » 18.05.2009, 15:58

2_DRON_
Ну вот опять двадцать пять... :-( На версии 0.9.6.6 перестал работать foo_snap. Надо опять что-то делать.
alex_realist M
Аватара
Репутация: 140
С нами: 15 лет 7 месяцев

Сообщение #73 DRON » 18.05.2009, 16:24

alex_realist:Ну вот опять двадцать пять...
Не далее чем пол часа назад поставил себе 0.9.6.6 и никаких проблем замечено не было, все плагины исправно работают.
Надеюсь имя файла у вас foo_snap2.dll?
DRON M
Аватара
Откуда: Санкт-Петербург
Репутация: 113
С нами: 15 лет 10 месяцев

Сообщение #74 meDveD » 18.05.2009, 16:31

подтверждаю, что не работает
meDveD M
Откуда: SPb
Репутация: 52
С нами: 17 лет 2 месяца

Сообщение #75 DRON » 18.05.2009, 16:41

У меня DUI, а у вас?
DRON M
Аватара
Откуда: Санкт-Петербург
Репутация: 113
С нами: 15 лет 10 месяцев

Сообщение #76 meDveD » 18.05.2009, 16:47

да и то и то не работает (Win 7 RC x86)
meDveD M
Откуда: SPb
Репутация: 52
С нами: 17 лет 2 месяца

Сообщение #77 DRON » 18.05.2009, 17:11

meDveD:(Win 7 RC x86)
А на XP? Просто семёрки у меня нет и врядли я смогу что-то исправить, если дело в ней.
Вобщем хотелось бы знать какие именно плагины перестали работать, зависит ли это от версии Windows и зависит ли это от версии foobar-а?
DRON M
Аватара
Откуда: Санкт-Петербург
Репутация: 113
С нами: 15 лет 10 месяцев

Сообщение #78 alex_realist » 18.05.2009, 17:20

2_DRON_
Конечно foo_snap2.dll от 25.04.2009. И в DUI не работает и в CUI тоже в XP.
alex_realist M
Аватара
Репутация: 140
С нами: 15 лет 7 месяцев

Сообщение #79 alex_realist » 18.05.2009, 17:23

Скорее всего в новой версии не работает из-за Updated third-party component blacklist. Что-то Питер опять намутил.
alex_realist M
Аватара
Репутация: 140
С нами: 15 лет 7 месяцев

Сообщение #80 alex_realist » 18.05.2009, 17:30

Проверил остальные. У меня работает только foo_minimize_on_close2.
alex_realist M
Аватара
Репутация: 140
С нами: 15 лет 7 месяцев

Пред.След.

Вернуться в Плагины