При переносе на другую машину Foobar отказывается открыв

Список разделов Другое Архив

Описание: Архив старых тем

Сообщение #1 Malfet » 20.12.2007, 01:35

Подозреваю, что вопрос ламерский, но для меня - важный :)
Стоит у меня слегка модицифированная (что-то добавил, что-то убрал, где-то модицифировал - но внешне суть та же) сборка от Rialto. Если ее упаковать, перенести на друую машину и там распаковать то плеер жалуется, что не может загрузить dsp_crossfader, managedWrapper и foo_uie_trackinfo_mod. Все файлы естественно лежат в каталоге Components. trackinfo я правил - чтобы он больше информации по треку показывал, остальное особо не трогал... Почему он их перестает видеть на другой машине? В чем может быть дело?
Заранее спасибо.
Malfet
Автор темы, Новичок
Репутация: 0
С нами: 9 лет 3 месяца

Сообщение #2 Rialto » 20.12.2007, 21:07

2Malfet

Нехватает системный библиотек, которые стояли на предыдущей машине, а на этой отсутствуют, вот foobar и ругается, что не плагины не могут их найти.
Поставь vcredist_x86_sp1.exe (2.59 MB), и посмотри будет ли теперь ругаться foobar, если будет, то ищи каких именно библиотек не хватает конкретному плагину.
Rialto
Бывалый
Аватара
Репутация: 10
С нами: 10 лет 9 месяцев

Сообщение #3 Malfet » 21.12.2007, 19:28

Ага, спасибо - понял. Действительно ламерский - проверил сами компоненты на которых шли жалобы и понял, что им .NET Framework нужен. Странно, что фубар вместо того, чтобы  пожаловаться на нехватку компонентов говорил о неверной их настройке - есть же там формулировка о необходимости какой-то депенденси...
Malfet
Автор темы, Новичок
Репутация: 0
С нами: 9 лет 3 месяца


Вернуться в Архив