CaTRoX (QWR Edition) проблемы при установке

Список разделов Аудиоплеер foobar2000 Есть вопрос!

Описание: У вас проблемы с foobar2000 и вам необходима помощь? Спрашивайте здесь!
Правила раздела: Одна тема — один вопрос или группа связанных вопросов. Обязательно формируйте внятный заголовок, максимально отражающий суть. Подробно описывайте проблему. Не забывайте указать версию плеера, название сборки, по возможности добавить скриншоты проблемы.

Сообщение #1 maniac736 » 24.07.2019, 19:51

Сборка CaTRoX (QWR Edition) опубликована https://github.com/TheQwertiest/CaTRoX_QWR/releases
Установка сборки была произведена полностью в соответствии с инструкциями опубликованными создателем данной сборки https://github.com/TheQwertiest/CaTRoX_QWR/wiki/Installation
Однако как при первом, так и при последующих запусках сборки постоянно возникает одна и та же ошибка связанная со скриптом основанным на foo_jscript_panel ver.2.1.4
Текст ошибки
Спойлер
Error: JScript Panel v2.1.4 (Top Panel)
Ошибка выполнения JavaScript:
Недопустимый вызов или аргумент процедуры
File: E:\Foobar2000\Someone_else's_assembly\Catrox\\themes\CaTRoX\Scripts\Panel_Top.js
Line: 440, Col: 5
<source text only available at compile time>

Скрипт:
Спойлер
// ==PREPROCESSOR==
// @name "Top Panel"
// @import "%fb2k_path%\themes\CaTRoX\Scripts\js_marc2003\js\lodash.min.js"
// @import "%fb2k_path%\themes\CaTRoX\Scripts\js_marc2003\js\helpers.js"
// @import "%fb2k_path%\themes\CaTRoX\Scripts\Common.js"
// @import "%fb2k_path%\themes\CaTRoX\Scripts\Control_ContextMenu.js"
// @import "%fb2k_path%\themes\CaTRoX\Scripts\Panel_Top.js"
// ==/PREPROCESSOR==

Особенность сборки заключается в том что там используется мод плагина foo_jscript_panel ver.2.1.4 компилированный из исходных кодов самим создателем сборки для адаптации под её особенности. Буду рад любым советом потому что у меня похоже из-за этого скоро мозг взорвётся :sad:


Текст самой ошибки в скрипте линия 440, столбец 5
Спойлер
var is_youtube_video_displayed = g_has_modded_jscript ? fb.IsMainMenuCommandChecked('View/Visualizations/Video') : false;

Оказывается данная проблема решается просто и весьма банально. Данная ошибка связана с плагином foo_youtube, а точнее с его настройками. На случай если кто-то тоже столкнется с такой же ошибкой на данной сборке - после установки в настройках плагина foo_youtube установите английский язык вместо русского.
maniac736 M
Автор темы, Бывалый
Аватара
Возраст: 41
Откуда: Россия Иркутск
Репутация: 9
С нами: 2 года 1 месяц

Вернуться в Есть вопрос!